ionic应用签名后在低版本(4.1/4.2)都安装不了,ionic platform add android自动添加的Android-23
发布于 3个月前 作者 qiao520 626 次浏览 来自 问答

最近做了一个ionic应用,应用做完,ionic build android --release、签名之后,在我的手机4.4版本的Android可以安装,但是拿到4.1/4.2版本的Android机就安装不了,不知道为什么,我想要build低版本Android机能支持的apk,哪位大神知道怎么解决吗

我有做如下尝试: 应用目录下的config.xml中的minSdkVersion也改到15; 将Android sdk中的platphorms的包都换成api16、API17、API18,都尝试过,但build --release都出错; 我发现ionic platform add android自动添加的Android-23,然后我就猜会不会是ionic platform add android的时候指定了Android的版本,我就尝试从这里解决,但都解决不了。

我使用到的版本: Android sdk的build-tools的版本是5.1 cordova-android@5.2.2 ionic @ 2.0

回到顶部